Funktionsbeschreibung

Allgemeine Funktionen | Betriebsarten, Programminfos, Vollversion | Optionen | Datenreihen | Punktberechnung aus Schattenwurf

Das vorliegende Kapitel behandelt weiterführende Themen, die im Kapitel "Schnelleinstieg" nicht angesprochen wurden. Sie sollten daher vorher dieses Kapitel gelesen haben. Die Bedienung des Editors für die 3d-Szene wurde in ein eigenes Kapitel ausgelagert (siehe nächstes Kapitel "3d-Editor").

Allgemeine Funktionen

Hilfe-Fenster

Helios bietet im Menü Hilfe zwei Hilfefenster an:

Im Fenster Bedienung werden die einzelnen Funktionen und die wichtigsten Bedienmöglichkeiten von Helios kurz erklärt.

Im Fenster Navigation 3d werden alle Navigationsmöglichkeiten in der 3d-Szene aufgeführt. Die wichtigsten Funktionen wurden bereits im Kapitel "Navigation in der 3d-Szene" erklärt. Für alle anderen (eher selten benötigten) Funktionen lesen Sie bitte diese Hilfeseite.

Wiederherstellung der Nutzereinstellungen

Wenn Sie Helios beenden, werden alle vorgenommenen Einstellungen gespeichert und beim nächsten Start wieder hergestellt. Hierzu gehören die gewählte Sprache, die Größe und Position der Fenster, die Liste der gespeicherten Orte und vieles mehr.

Wenn Sie diese Einstellungen speichern wollen, können Sie diese in eine Datei exportieren. Wählen Sie hierzu im Menü Extras den Eintrag Export... und geben Sie die gewünschte Datei an, in der die Einstellungen gespeichert werden sollen.

Einmal gespeicherte Einstellungen können jederzeit (z.B. nach Installation auf einem anderen Rechner) wieder hergestellt werden. Wählen Sie hierzu im Menü Extras den Eintrag Import... und geben Sie die gewünschte Datei an.

Wenn Sie alle Einstellungen auf die Werkseinstellungen zurücksetzen wollen, wählen Sie im Menü Extras den Eintrag Zurücksetzen....

Funktionsweise Schattenberechnung

Bei der Schattenberechnung in einer 3d-Szene wird wie folgt vorgegangen:

Zunächst werden alle betreffenden Flächen trianguliert und unterteilt in Flächen, die Schatten werfen, und Flächen, auf die Schatten geworfen wird. Für jede Fläche, auf die Schatten geworfen wird, wird anhand der Schatten werfenden Flächen das Schattenpolygon berechnet, das genau die abgeschattete Teilfläche darstellt. Das Schattenpolygon wird schießlich noch etwas von der betrachteten Fläche abgehoben, um eine saubere Darstellung zu gewährleisten.

Der Abstand des Schattenpolygons von der betrachteten Fläche und der Grad der Transparenz können in den Optionen eingestellt werden.


[Nach oben]